设为首页   加入收藏
首 页 通知公告 商密动态 政策法规 信息展示 办事指南 下载服务 知识园地 密码标准化
   2017年10月21日 星期六
      
  通知公告 更多
国家密码管理局关于做好商用密码产品生产单位审批等4项行政许可取消后相关管理政策衔接工作的通知(国密局字 〔2017〕336号)
电子政务信息系统使用电子认证技术实用问答
关于使用SHA-1密码算法的风险提示
国家密码管理局公告(第31号)
关于停止RSA算法1024位密钥对服务的公告
国家密码管理局公告(第30号)
国家密码管理局公告(第29号)
 
 当前位置: 知识园地 > 正文
网银SSL证书部署注意有漏洞
  来源: 计算机世界(总第1321期) 2010年12月14日
 


    部署SSL证书是保证网银系统和电子商务网站机密信息传输安全的最有效、最安全的解决方案,也是最简单的解决方案(因为已经标准化、所有软件都支持)。但是,用户往往最容易忽略SSL证书是否得到正确配置,而不安全的配置将导致安全漏洞,给重要系统带来巨大安全隐患。
    根据WoSign最新推出的“SSL证书免费健康体检系统”的测试结果表明:我国所有已经部署了SSL证书的网银系统和第三方支付系统的服务器都有不同程度的SSL安全配置问题(有些甚至囊括了所有已知的安全漏洞),主要涉及以下几个方面的问题:
    1.许多网银网站都没有关闭不安全的传统SSL通信重新协商机制,更谈不上补漏支持安全重新协商机制了。
    美国信息安全专家Marsh Ray与Steve Dispensa于2009年9月份公开了他们发现的TLS/SSL协议的安全漏洞,攻击者可以利用这种漏洞劫持用户的浏览器,并伪装成合法用户。由于 TLS协议中的密钥再协商功能使得验证服务器及客户机身份的一连串动作中存在前后不连贯的问题,因此给了攻击者可乘之机。不仅如此,这种漏洞还给攻击者发起Https攻击提供了便利,Https协议是Http与TLS协议的集合体。
    微软于2010年2月11日发布了第977377号安全公告《Microsoft 安全公告:TLS/SSL 中的漏洞可能允许欺骗》,要求用户在受影响的系统上采用禁用TLS和SSL重新协商支持的替代方法,以帮助保护连接到此类服务器的客户端,免被该漏洞所利用。微软于2010年8月16日发布了此漏洞的补丁《MS10-049:SChannel 中的漏洞可能允许远程代码执行》,凡是允许自动升级的系统都会自动修复此漏洞,使得系统能支持新的TLS/SSL协议扩展项,即支持Secure Renegotiation (安全重新协商)。Apache服务器软件也提供了相应的补丁。
    但是,这么重大的安全漏洞并没有引起国内部署了SSL证书的重要系统的重视和采取相应行动。所幸的是:如果服务器采用的是Windows Server系统并支持自动升级的话,微软已经自动升级和修复了此安全漏洞。但还有许多服务器软件并不支持自动升级功能,特别是被广泛使用的Apache 服务器软件,必须人工升级到最新版。
    2.有许多网站仍然支持不安全的SSL V2.0协议。
    SSL V2.0协议是NetScape公司于1995年2月发布的,由于V2.0版本有许多安全漏洞,所以,1996年紧接着发布了V3.0版本。目前主流浏览器(IE、火狐、谷歌、Safari、Opera等)都已经不支持不安全的SSL V2.0协议。SSL V2.0协议的主要安全漏洞有:同一加密密钥用于消息身份验证和加密;弱消息认证代码结构和只支持不安全的MD5摘要算法;SSL握手过程没有采取任何防护,这意味着非常容易遭遇中间人攻击;虽然使用TCP连接关闭,以指示数据的末尾,但并没有明确的会话关闭通知(这意味着截断攻击是可能的,攻击者只需伪造一个TCP FIN,使得接受方无法识别数据结束消息的合法性即可)。
    3.有些网站仍然支持不安全的40位和56位加密套件。
    破解40位DES算法只需几秒钟,破解50位DES算法也只需几天时间,但破解128位3DES算法则需要0.25个10的21次方年才能破解,所以,Web服务器软件必须只能支持128位以上的加密套件,而关闭不安全的40位和56位加密套件。
    4.有些网站的SSL证书和/或其根证书都是不安全的1024位公钥。
    微软和火狐等将于2010年12月31日停止支持1024位公钥证书,并于2013年12月31日之前删除所有不安全的、低于2048位的根证书。为了服务器的安全,必须部署从根证书、中级根证书和用户证书整个证书链都是2048位或高于2048位的SSL证书。
    5.许多网银系统都使用自签证书或其他不支持浏览器的SSL证书,几乎所有自签证书都存在以上安全问题,并且自签证书很容易假冒和受到中间人攻击。
    为了重要系统的安全,千万不要使用自签的SSL证书,避免因此产生的巨大安全隐患和安全风险,特别是重要的网银系统、网上证券系统和电子商务系统,一定要选购专业证书颁发机构颁发的全球信任的支持浏览器的SSL证书,因为证书中许多环节的安全问题是一般的自签证书颁发系统都没有很好解决的技术问题。
    6.有些网站的SSL证书安装时并没有安装中级根证书。
    这对于IE浏览器是没有问题的,但火狐浏览器访问时会有安全警告。为了让用户能正常访问部署了SSL证书的网站,必须正确安装中级根证书。
    SSL证书是解决网银系统和电子商务网站账户登录安全和账户机密信息安全的惟一可靠技术手段,但是千万不要以为部署了SSL证书就万事大吉了,不安全的部署可能比不部署还可怕,因为用户看到有安全锁标志就以为安全了,实际上却存在安全漏洞和安全隐患。望所有部署了 SSL证书的网站都使用相关安全工具来自查,发现有哪些安全漏洞后及时联系证书销售方获得技术帮助。


返回
 
版权所有:上海市密码管理局
技术支持:上海鹏越惊虹信息技术发展有限公司
(建议使用IE7浏览器、将电脑显示屏的分辨率调整为1024*768浏览本网站)